​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​

This laptop/tablet has the cursor hidden unless I plug in a hardware mouse.

How do I get it to show the mouse so it works better with eye tracking?

asked 29 Jul '15, 14:06

phyatt's gravatar image

phyatt ♦♦
15792364
accept rate: 8%


Installing a virtual HID device driver should also work, such as a Wacom virtual mouse driver

http://support.lenovo.com/us/en/downloads/ds004071

UPDATE: Tested on Windows 8.1 x64, using the driver link above, worked great.

Basically it installs the "Pen Tablet" version of the Walcom drivers and makes Windows think that another mouse like device may be plugged in all the time, even when there isn't one.

One strong advantage this solution has over the TouchMousePointer solution, is it responds properly with the correct cursor when you hover over links or you are on top of a touch area. And it is slightly more responsive (probably by 1/10 of a second). And it doesn't require any configuration after installing.

TouchMousePointer does allow for larger pointers, and has a bunch of other features.

link

answered 03 Aug '15, 13:34

phyatt's gravatar image

phyatt ♦♦
15792364
accept rate: 8%

edited 03 Aug '15, 18:40

It looks like the easiest way to fix this is to edit the registry:

A post on EightForums.com describing the issue: How to display Windows 8 mouse pointer by default

Another post on answers.microsoft.com.

A .reg file that will do the change the EnableCursorSuppression is here:

(Right click on the link and select Save link as..., then save it to your computer as a .reg file. Double click the file and it will apply it to the registry.)

cursor_suppression_fix.reg

Be sure to restart the computer after applying the registry change.

If that doesn't work, then maybe Mouse Move at CodePlex may help.

link

answered 29 Jul '15, 14:14

phyatt's gravatar image

phyatt ♦♦
15792364
accept rate: 8%

edited 29 Jul '15, 14:24

Duplicating the Issue/Diagnosis

When testing to see if this had been fixed, I used a Windows 8.1 machine and disconnected the hardware mouse. The mouse cursor would disappear within a second or so.

Documentation about CURSOR_SUPPRESSED in Windows 8

This feature is alluded to under ShowCursor and GetCursorInfo and CursorInfo Structure on MSDN.

Value Meaning
CURSOR_SUPPRESSED
0x00000002
Windows 8: The cursor is suppressed. This flag indicates that the system is not drawing the cursor because the user is providing input through touch or pen instead of the mouse.
Windows 8: Call GetCursorInfo to determine the cursor visibility.

This function sets an internal display counter that determines whether the cursor should be displayed. The cursor is displayed only if the display count is greater than or equal to 0. If a mouse is installed, the initial display count is 0. If no mouse is installed, the display count is –1.

Google Searches

The following searches on google yielded almost no help.

Cursor_Suppressed touchscreen windows 8
showcursor windows 8 hidden cursor
CURSOR_SUPPRESSED touchscreen computer
CURSOR_SUPPRESSED
register software hid mouse input device windows
register hid mouse input device windows
showcursor windows 8 hidden cursor

The search that was helpful was:

fake mouse driver

Some of the mouse replacements/additions that were tried include:

Dead Ends

Some other paths that didn't pan out include:

  • Pressing Alt Ctrl Delete to fix it.
  • Pressing Fn+F6 (toggle show cursor next to toggle dual display)
  • Control Panel > Mouse Settings/Properties > Pointer Options >
    • (check) Display pointer trails
    • (uncheck) Hide pointer while typing
  • Control Panel > Mouse Settings/Properties > Pointers > (check) Enable pointer shadow
  • Control Panel > Ease of Access Center > Make the mouse easier to use > Turn on Mouse Keys

Solution #1: Install Walcom's Virtual Mouse HID driver aka Pen Tablet Drivers

This works really well and addresses the issue head on. See the other posted answers for details on downloading the driver from Lenovo's website.

Solution #2: TouchMousePointer

Download and install TouchMousePointer from here.

Change the settings to the following:

  • Current Mode (tab) > Fullscreen mode
  • Visualize pointer (tab) > (check) Fake cursor

alt text

Now a cursor is shown all the time.

link

answered 31 Jul '15, 18:21

phyatt's gravatar image

phyatt ♦♦
15792364
accept rate: 8%

edited 03 Aug '15, 18:42

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×41
×17
×9
×4
×1

Asked: 29 Jul '15, 14:06

Seen: 3,892 times

Last updated: 03 Aug '15, 18:42

Copyright © 2014-2017 EyeTech Digital Systems Inc. All rights reserved. | About | FAQ | Privacy | Support | Contact | Powered by BitNami OSQA